Alkatronic not uploading data

Hi

Been having some issues with cloud function.

For a couple of weeks now no measurements have been uploaded to my app or cloud. Its testing and dosing properly, but no data is getting uploaded. I've been away during this time a lot and have not had time til the last week to look into whats not working. I thought at first it was my wifi, other things connected has been going on and offline and since I changed router lately I thought it was that. So I went back to the old router wich have been working fine before. Also during the time of being offline my reagent needed changing wich I did and told the machine via the app.

Now, this is the case.

  1. I have gone through the whole troubleshooting step by step.
  2. I can see in my routers settings that the alkatronic is infact online.
  3. It keeps uploading other information, like the reagent needing refilling. When I changed back to my old router it was sending me 1 massage a minute for a full 24 hours telling me I needed to refill reagent until I turned that function of completely. If I try to turn it back on it starts sending me 1 message a minute telling me its time to refill reagent. I have tried to tell it I have refilled but it doesn't matter.
  4. Upload mode is on. (I just tried to turn it of and back on, waiting to see if that helps)
  5. I have come to my wits end, I have no idea what to do anymore. I´ve tried turning the machine off and on, I´ve tried reinstalling the app. I´ve tried most things I can think of but now I need some new Ideas.
  6. The router have been working fine before so I really don't think its about that not working, especially since Im getting other info from the machine.

Hi again

Sorry for the late reply, been working nights the last few days 🙂

It has now stopped sending those insane amount of messages, it is however sending one after each measurement although alerts are off.....

It's now uploading measurements, even older, to cloud but I still can't see them in the app...

@frida-engvall now I was reading your message correct, you did correct.
That should be a cloud issue.
Actually I have sometimes experienced the same but suddenly it is stopping so it’s nothing in the Alkatronic fw but in cloud side.
If it continues send a support ticket/mail to Focustronic (Eric) and they will fix it.

@frida-engvall hi
Jonas here. Alert buttons is for the dKH high and low alert.
To disable reagent alert just put 0 ml (let me double check that first have not machine in front of me now).

@Frida-Engvall Hi there, are you still getting the reagent alerts? the team should have fixed this for you and would like to check if that's the case. Would be good to know it is fixed. thanks!

Question @Eric, do you guys have a list of ports that definitely need to be opened/forwarded in our routers for the Alkatronic to communicate to the cloud? If it's standard 443, 80, or others then there shouldn't be a router issue I would imagine.

@frida-engvall can you try to reboot the Alkatronic and see if the alerts still sending? one of the reason is that as you said, the new router had some issues and therefore some of the data were uploaded during that time. when you reverted back to the old router, Alkatronic is uploading the history data to the cloud and each test record will trigger an alert so if it is uploading a lot of data, it may need to get past that. hope this is now solved but if not, please contact us on the Facebook page for quicker replies.

@mitchel-hayes I´ve done what you said more than once, no change. Ive also tested how it switches between bluetooth and WIFI and that seems to be working also (i´ve been in my routers settings doing this).

One thought that I had was that the insane amount of messages being sent to me about "it's time to refill reagent" i somehow blocking other measurements being uploaded? As I wrote it is currently sending me 1 message per minute saying this. Another question is how do I stop these messages from being sent like this? Its a crazy amount! But that might be another thread ;).

All my setting in app seems fine, and it is apparently sending stuff to me since it won't stop telling me to refill reagent (even though I have...) so I take it something is working there (although a little bit too well..... 🙂 )

Ill give you some pics as well

4_1533055582747_Screenshot_20180731-170214.jpg 3_1533055582747_Screenshot_20180731-170150.jpg 2_1533055582747_Screenshot_20180731-170142.jpg 1_1533055582746_Screenshot_20180731-170132.jpg 0_1533055582746_Screenshot_20180731-162557.jpg

The last image is to give you an idea of the insane amount of alerts Im getting, ALTHOUGH my alert is off. #goingabitcrazyhere

@frida-engvall said in Alkatronic not uploading data:

edit: Since I turned upload mode off and then back on it has started telling me to refill reagent again, although that alert is turned OFF.

@Frida-Engvall, I honestly think that there is something going on with the web services that receive the information from the Alkatronic (not 100% sure, but I myself have been experiencing this issue as well). I was able to get my unit communicating again. This is what I did:

  1. Restart the unit.
  2. Going into the mobile app, activating action mode
  3. Saving that
  4. Closing the mobile app

I actually watched in my router the status go from inactive to active. I've had to do this a few times recently when it stopped communicating. It's either what I mentioned above about their server potentially not being able to handle the request (which would be totally insane unless they are being flooded with messages) or the unit somehow is getting stuck in BT mode and not totally switching to WIFI mode.

Let's hope that this is something that will be resolved in the next firmware release because one of the advantages to having the unit is that you can see the trends in the web portal. I have mine sending measurements to my Apex and do not want to rely on those when the web portal is so much better.

edit: Since I turned upload mode off and then back on it has started telling me to refill reagent again, although that alert is turned OFF.